Polaris ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey guys, my 06 Polaris Ranger TM is not getting fuel to the carb. I have cleaned the carb, replaced the fuel filter and have also replaced the fuel pump. Still no fuel. If I manually place fuel into the hose going from the tank to the fuel pump, it starts and runs fine for a few minutes until it runs out of what I put in the line, so I now think pump and carb are working correctly. I have worked my way back down the line, and all that is left is the fuel tank itself. Is there something in there which could be the issue? I am a little leary of prying off the rubber grommet holding what I guess is an intake tube when I am not sure I need to do so and I may break something, but that's the only thing left I can think of. Anyone ever had this problem? And how hard is it to remove the insides of the tank? Thanks so much!
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board!:med:
 

·
Registered
Joined
·
4,243 Posts
how did you replace the fuel pump if you didnt take the top off the tank, the pump is electric and in the tank on rangers
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Not on this one. The 2006 Ranger TM was a very basic model for work around a farm/ranch. The fuel pump is mounted to the frame between the tank and the carb. It is not electric, and operates with a vacuum and/or gravity I think. Thanks for the reply, though.
 

·
Registered
Joined
·
1 Posts
Hello. I have the same issue and was wondering how this was resolved? I have an 05 Ranger TM with the same configuration and have replaced the fuel pump and the pick up lines and others are all clear. It will not pump while cranking. Suction from the crank seems adequate. Any help is appreciated.
 

·
Registered
Joined
·
2 Posts
Hello. I have the same issue and was wondering how this was resolved? I have an 05 Ranger TM with the same configuration and have replaced the fuel pump and the pick up lines and others are all clear. It will not pump while cranking. Suction from the crank seems adequate. Any help is appreciated.
I finally took mine to a cart shop and they discovered that the pick up tube inside the tank was rotten. Now I'm struggling to find other parts. So many parts aren't available for this model. So frustrating.
 
1 - 7 of 7 Posts
Top