Polaris ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1 (Edited)
hi fellow wheelers
I've got an '07 500 X2 with about 1400 miles on it & close to 168 hours. mainly use this for plowing in the winter and trail ridding in the summer. we ride pretty hard on the trail mix of mud/rock/dirt with some bush whacking/new trail or linking trails together. all I've done for the past 6 years is change the oil before every summer. What else should I be doing? Runs great except it vibrates more than usual, could be the body though. Please any info would be great. if you could let me what I can do myself and what i need to take it in for that would be great. I would ask my local Polaris dealer but they can be difficult and snobby when i don't know a detail or sepecific part. Let a brother know will ya!
 

·
Registered
Joined
·
164 Posts
Would be a good idea to service trans. Frt and rear diff fluids.air filter.fuel filter. Vibration ck for possible broke trans or motor mount.. ck wheel brgs for play.
 

·
Registered
Joined
·
2,846 Posts
Welcome to the forum! Grease the fittings, change the tranny fluid & the angle drive fluid. Also check your cvt belt for wear. If you don't have one get a service manual. It'll save you some aggravation.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
Thanks guys. appreciate the advice. will start working on it.
 

·
Registered
Joined
·
2,104 Posts
The X2 doesn't have a rear diff. It has a tranny and it is all one piece. I would change the front difff fluid and the tranny fluid. For vibration you could have a tire out of round, U joints going bad, loose lug nut and other possible things. Check your air filter also.

Ronnie
 
1 - 5 of 5 Posts
Top