Polaris ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My 08 sp 800 will intermittent charge. It seams to happen more when I'm plowing and use the winch a lot. I've mounted a volt gauge to the fairing and it will go from stumbling to full power and the volt meter will show a over charge (18v) when the rpm comes up passed 3k, until than it will read 13v. Sometimes when I start it it will be great, other times it be low volt till 3k rpm or not charge at all and not show the rpm.

I've changed the battery, regulator and checked the wiring, guessing it down to the stator but I haven't caught it when it's acting up to test.

Will stators work intermittent?
 

·
Registered
Joined
·
5,067 Posts
Stators can do lots of different things including working intermittently, but one thing a stator will not do is over charge - that control is solely the job of the rec/reg. Either you have an intermittent rec/reg (not likely) or a poor connection on the battery or a ground.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I'll pull all the body work off and chase every connection this time, hopefully I find something, last time I just did the grounds but I might have missed one.

I pushed snow this afternoon and noticed that the biggest drop happens when the fan kicks on, than it starts missing and starts putting out 18v once it gets above 3k rpm. Once the fan shuts off, it's back to normal.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
I found the stator and regulator were dead. Replaced both and I still have the problem when the fan come on, it robs all the power from the machine. I thinking now it's the pcm not distributing the power properly?
 

·
Premium Member
Joined
·
7,485 Posts
What the fan fused at?? I would think it would blow if it was pulling that much juice!!
 
1 - 5 of 5 Posts
Top