Polaris ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
just got the magneto off, expecting to find a ruined 1 way clutch, and to my horror, discovered ALL 8 cap screws had broken off and been ground around behind the magneto and starter gear, the aluminum case is scarred up pretty badly, and the remainder of the screws are still in the back of the magneto, luckily i have a friend that works in a machine shop, and will get these taken out Sunday and other than getting 8 new cap screws, I'm have all the parts for reassembly.
I've flushed the crankcase with gasoline a couple of times, and have an extra oil filter to change after an hour or so of run time, the oil drain plug is a magnetic type and was loaded with metal chips.
wish me luck! oh and will locktite the cap screws!
Rick, Ore :mad1::mad1:
 

·
Premium Member
Joined
·
20,001 Posts
WOW! Thats something!
 

·
Registered
Joined
·
38 Posts
Discussion Starter #3
OK! after a hit and miss with a gummed up carb, this thing screams! have about 20 minutes on it now, and judging from the exhaust smell, it's still got race gas with a touch of nitro in the tank! also seems to have some timing chain noise as well, so something I'll have to watch, going to go to Woodruff OHV trail system above Prospect Oregon Thursday for a few days, give it a thorough wringing out! :banana:
Rick , Ore
 

·
Registered
Joined
·
38 Posts
Discussion Starter #4
OK!!!! put around 120 miles on it over 4 days, after a few minor adjustments and a filter change, I'm very happy with it! this thing has got power!:undwech:
the suspension and the IRS allowed me to blaze thru trails that i had to pick my way thru with my Z400 ( dodging big rocks) I still grit my teeth when i take a big rock down the middle and laugh when i miss it completely!:eek:mfg:
still need to deal with a couple little things i noticed, but looking forward to taking it to the dunes over Labor day :daz:
Rick, Ore
 
1 - 4 of 4 Posts
Top