Polaris ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I have a 11 Sportsman 800 and it was flashing hot after about 5-10 minutes of running. I thought it maybe a clogged up radiator due to riding it in the mud pits a while back. So I disassembled the atv and cleaned out the radiator and that wasnt the problem. The fans would kick on and you could touch the radiator and it would be cold. So I figured it maybe the thermostat. I think they are useless so I want to bypass it like Ive done on my cars in the past. Is there any reason in particular this would hurt my atv if I did. And Im also concerned cause there seems to be a knock coming from the motor now but there is no smoke or power loss. I havent even driven it 15 minutes since it started doing this. Any thoughts?
 

·
Registered
Joined
·
479 Posts
I have a 11 Sportsman 800 and it was flashing hot after about 5-10 minutes of running. I thought it maybe a clogged up radiator due to riding it in the mud pits a while back. So I disassembled the atv and cleaned out the radiator and that wasnt the problem. The fans would kick on and you could touch the radiator and it would be cold. So I figured it maybe the thermostat. I think they are useless so I want to bypass it like Ive done on my cars in the past. Is there any reason in particular this would hurt my atv if I did. And Im also concerned cause there seems to be a knock coming from the motor now but there is no smoke or power loss. I havent even driven it 15 minutes since it started doing this. Any thoughts?
I think you might have a problem with the temp sensor but I'm not sure and I don't think it's a good idea to remove the thermostat. And if you hear the knocking sound from the right side of the engine that is also normal. If this is your first Sportsman or your first Polaris it will take time to get used to the noises coming down from the engine.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Oh so normally bad noises are common on these? Starting to sound like a honda car, and by that i mean junk. And ill replace the thermo then just to be safe. And the sensor next.
 

·
Registered
Joined
·
4,081 Posts
Hot engine, cold radiator, I would say thermostat first, and if that doesn't fix it then look into the water pump

I agree 100%. Cold rad means no or insufficient flow. That means blockage or little to no fluid movement.

Good luck,

CW
 

·
Registered
Joined
·
479 Posts
Oh so normally bad noises are common on these? Starting to sound like a honda car, and by that i mean junk. And ill replace the thermo then just to be safe. And the sensor next.
The 800 twins are noisy specially at idle. Did you bought it new or used?
 

·
Registered
Joined
·
69 Posts
Hey
I have an 09 800 and the engine ticks and weird idle are normal..had the same issue with it running hot.. turned out to be the thermostat in my case..
 
1 - 7 of 7 Posts
Top