Polaris ATV Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
110 Posts
Discussion Starter #1
Hey guys, I see alot of people on here having the same issues that I am having with the factory 14 steel wheels on the xp. It seems like everytime I go out riding I get a flat from the air leaking out around the bead or I blow the tire off the bead completely. It happens to all 4 of my wheels. I saw that people said the stock tires where their issues so I bought some STI black diamonds and am still having the same issue. I have tried bead sealer, slim, putting silicone on the rim and them setting the bead. Im convinced its the wheels. So I have beee looking a new wheels and Im worried that ill have the same issue with my new ones unless I go with bead locks.
Any thoughts?
 

·
Registered
Joined
·
2,350 Posts
What size tires are you running and at what pressure?
 

·
Registered
Joined
·
110 Posts
Discussion Starter #4

·
Registered
Joined
·
2,350 Posts
Meant to type SIZE as well.......

Makes no darn sense at that pressure. I could understand if you were running <4psi
 

·
Registered
Joined
·
110 Posts
Discussion Starter #6
26x9 and 26x11
nothing crazy
its just weird that 2 sets of tires are having the same thing happen. The dealer said the rims were fine, but I dont trust them.
 

·
Registered
Joined
·
2,350 Posts
have you looked at the wheel bead seats? No rust at all?
 

·
Registered
Joined
·
110 Posts
Discussion Starter #8
have you looked at the wheel bead seats? No rust at all?
none at all, it has been happening since it was new. (its got 300 miles and is less than 6 months old.)
 

·
Registered
Joined
·
110 Posts
Discussion Starter #9 (Edited)
I would like to run the tires at a lower pressure but they dont stay on now. I guess my question is should i get aluminum rims or get some beadlocks

the plus side of all of this is that I am really good at getting tires back on the rim on the trail.
 

·
Registered
Joined
·
193 Posts
I don't know what to tell you. My 09 xp has been running 5 rear, 7 front for several hundred miles with Zillas. One of the fronts has an outside edge rock dent over 3/4 in. and I've never lost a bead. My other atv is a grizzly 660 and has been running black diamonds at 3# all around (sti slick kote hd1 beaded at 15#) with no problems for a couple months. Fingers crossed. The bd's are really stiff walled too 12 inch tires.
I guess I'd take them to a tire pro and see what he says?
You've got me scared as I'm taking them both on a long hunting trip in a couple weeks.
 

·
Registered
Joined
·
2,350 Posts

·
Registered
Joined
·
2,350 Posts
..... I have tried bead sealer, slim, putting silicone on the rim and them setting the bead.....

He stated he tried that already........also changed tires.
Has to be the wheels or valve stems.
 

·
Registered
Joined
·
6,824 Posts
I believe he stated he tried that already........also changed tires.
Has to be the wheels or valve stems.
Sorry i missed that.

Like posted above, try inflating them and dropping in a water tank, or mix up dish soap and water and spray in on the rim.


Thanks,

Will
2012 Sportsman 400HO.
 

·
Registered
Joined
·
2,350 Posts
I believe he stated he tried that already........also changed tires.
Has to be the wheels or valve stems.
Sorry i missed that.

Like posted above, try inflating them and dropping in a water tank, or mix up dish soap and water and spray in on the rim.


Thanks,

Will
2012 Sportsman 400HO.
No reason to be sorry Will.......... would have to be porous welds on the wheels
 

·
Registered
Joined
·
217 Posts
I can't see the valve stems being the problem, that and the tires changed and no difference, to me it points more to the wheels somehow.
jonny72888, what type of riding do you do.....?
 

·
Registered
Joined
·
2,350 Posts
Never heard of valve stems leaking?
 

·
Registered
Joined
·
110 Posts
Discussion Starter #18
Its not the valve stems. It leaks from the beads.

I live in new england and ride everything... snow, sand, mud, rocks, and woods trails.
I just ordered a set of Vision wheels. I just hope the tires are not messed up from the bead popping all the time.
 

Attachments

·
Registered
Joined
·
294 Posts
Your avatar looks familiar. Are you the same guy that blew his axles a while back?

Sounds like you may need some beadlocks for the kind of punishment you seem to be dishing out if you are. :rotflmao:
 

·
Registered
Joined
·
110 Posts
Discussion Starter #20
Your avatar looks familiar. Are you the same guy that blew his axles a while back?

Sounds like you may need some beadlocks for the kind of punishment you seem to be dishing out if you are. :rotflmao:
Yes I am. I cant seem to find beadlocks in the right offset.
 
1 - 20 of 24 Posts
Top