Polaris ATV Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
ok so i got this 1998 polaris explorer 300 so in the cold ill start it up it will warm but when i get on the throttle it just bogs out do any of you have experience with this or is it just mine
 

·
Registered
Joined
·
10,828 Posts
Nope - happens a lot from either water in the carb or gummed up jets - there are other possibilities, but those are the most common
 

·
Premium Member
2008 800 ho efi, 2019 850 SP premium
Joined
·
3,392 Posts
When you open the throttle it lets more air in, you then need more gas to mix with the additional air. If it's bogging out it is starved for gas
 

·
Registered
Joined
·
10,828 Posts
A jet kit is fine, but what size were the jets and who made them? Did you know some jets are sized by flow and others are sized by orifice diameter? A Keihin 155 and Mikuni 155 are different sizes and a Mikuni round jet flows a different amount of fuel than a Mikuni hex jet. Also, if water was the problem and the water is in the fuel tank, you may have just refilled the carb with water. Obviously (we think) it is starving for fuel, so do what is necessary to correct the problem or determine if the problem is fuel or spark related - maybe it's losing spark when the throttle is operated due to a defect in the throttle safety switch?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
[QUOTE="latebird, post: 1500765, member: 44066"
yeah i cleand out the gas put fresh fuel in it it starts and runs but when i get on the throttle it boggs out
 

·
Registered
Joined
·
10,828 Posts
Well then, re-jet the carb accordingly
 
1 - 8 of 8 Posts
Top