Polaris ATV Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
G'day All,

Got the old girl back together today, and took her for a spin.

Replaced 2 boots (cvman), front wheel bearings (girlracersrock), front A arm bushings (EPI) and all 3 gearcase fluids (Polaris).

From an Aussie point of view, this forum has been great because we don't have any aftermarket spare parts for Polaris over here.

So the question is:

How far do I get into it with the clutch?

I mean, it's working and everything, but has probably never seen a service or new belt.

It slips a fair bit on take off, it's better if you move on with the throttle a bit.

Should I just throw a new belt on, or should I clean or service it at the same time?

Is there a service kit for these?

I've seen some guys on these forums really get into it about this topic, going all out with later model units etc.

I also see EPI has a new clutch set, complete with belt.

I havent pulled the cover off yet, so don't know if it's a Team secondary or whatever. It has EBS on the cover.

I'm fairly handy, and have a fair few tools, but I must say that the pics and proceedures in the manual look fairly daunting.

I've thought about just spraying it out with brake cleaner and putting a new belt on.

Would love some advice from the experts.
 

·
Registered
Joined
·
603 Posts
well not an expert, but pick up a new belt from polaris, check the drive and driven clutches for wear, also wouldn't hurt to add a high altitude clutch kit for stock tires(unless your tires r bigger than stock). That would really wake it up.
 
1 - 2 of 2 Posts
Top