Polaris ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
I should have asked this a minute ago and just thought about it - I was trying to get the 2000 335 in gear last night, and it was tough moving it through the gear ranges. When I put it in low range it was tough to get back to neutral or any other gear. I finally did get it back.

Is there a good way to smooth this out so it shifts much smoother?
 

·
Premium Member
Joined
·
2,475 Posts
Is that while it's running? If so you likely have a clutch issue or maybe fast idle. If it is difficult to shift while not running, then it's likely an issue with shift linkage or internal transmission problem.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #3
Is that while it's running? If so you likely have a clutch issue or maybe fast idle. If it is difficult to shift while not running, then it's likely an issue with shift linkage or internal transmission problem.
It was idling - and it doesn't idle too fast. Seems like it's running in the idle range it should be.
 

·
Registered
Joined
·
167 Posts
The shift lever is supposed to have oil inside. Make sure the boot isnt torn and check the oil.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #5
The shift lever is supposed to have oil inside. Make sure the boot isnt torn and check the oil.
Okay. A visual inspection last night showed there were no boot cracks. I'll check and see how the oil level is in it probably Saturday. I appreciate the help!
 
1 - 5 of 5 Posts
Top