Polaris ATV Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My sportsman 500 started overheating on my last ride, the fan is running & the radiator is free of any mud or debris. Does this model have a water pump that could go bad or any other suggestions on a fix
 

·
Registered
Joined
·
4,243 Posts
Yeah it has a water pump but im bettin on dirty radiator, take fan shroud off and look carefully in lower inside corners, takes a lot of soaking and washing to get them clean sometimes.
 

·
Registered
Joined
·
75 Posts
When was the last time you changed the rad fluid
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board!
 

·
Registered
Joined
·
19 Posts
I have a mod on my fan i just have it stay on when u turn the key my quad never over heats from it now fan might die sooner but fans cheaper then doing damage to the engine.
 

·
Registered
Joined
·
91 Posts
Thanks I will take the shroud off & check it & I've never changed the fluid. I will try that also.
How old is the fluid in the radiator? If it is several years you may have clogged ports inside the radiator and will need to remove it and take it to a radiator shop and have them clean it out.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #8
Thanks I will check the flow on the radiator. I've never had any reason to check the fluid until lately. I have a toggle switch that I wired in for my fan that just stays on all the time after I replaced that sensor 3 times
 
1 - 8 of 8 Posts
Top