Polaris ATV Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Looking for a little help with my sons 50cc. I've basically cleaned everything from tank to bottom jet and this thing starts run for a couple min and just bogs down when u gas it. Not sure what runs automatic choke. Could I have a bad battery causing problem? Just running out if things to clean. Please help if guys have any suggestions.thanks
 

·
Registered
Joined
·
96 Posts
is the vent on the tank clear? Does it quit when you give it throttle or quit on its own after idleing for a bit?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Mostly when you gas it. It will rev at first then it will fade off like its running out of gas. Just bog down. It will start in a min or so and do the same thing again
 

·
Registered
Joined
·
96 Posts
Here are some suggestions that may or may not help.

-Try running with gas cap off.
-Take the line off the carb and see if the gas is running free.
-spray around seals to see if they are leaking.
-check compression.
-I read on another forum that a guy had the same problem as you and it turned out to be his oil injection was screwed up so he just mixes his gas and runs it old school.

Good luck, Mike
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Thanks mike. Basically I just went through carb and fuel lines and picked up battery yesterday gonna try and put back together Saturday. I appreciate the suggestions. Any chance you would know how to get wiring diagram. Just not sure what picks that automatic choke. Thanks again Dan
 

·
Registered
Joined
·
96 Posts
No i don't but google is a wonderful tool. Sure sounds like its starving for fuel. Have you checked the plug? If your choke is coming on i would think the plug would be black.
 

·
Registered
Joined
·
295 Posts
if it is 2 stroke might wanna check the crank seals they may be leaking when it warms up just a thought
 

·
Registered
Joined
·
7 Posts
Try the fuel lines. I had the same problem with my 500. Had the carb cleaned like 3 times befor finding out that my fuel lines where deteriorated inside and was just clogging everything up
 

·
Registered
Joined
·
7 Posts
Discussion Starter #10
Checked fuel lines when I cleaned out tank and carb. I tried turning in screw on carb for idle jet . I went I 3/4 from the 1.5 turns it was out. Seemed like it ran a lot better. Then being in Chicago it dropped 30 degrees in about two hours I rode it again and same thing bogged on idle after it warmed up.Not sure if idle jet is really that temp sensitive. So I ordered manual choke from what I read these electric chokes cause a lot of problems.
Thanks mills well see what happens
 

·
Registered
Joined
·
5,822 Posts
I'm having that same problem right now
Old thread - start a new thread and describe the problem you are having - when the problem arose, if the machine had been setting, year and model, any modifications, last time serviced, type of fuel used, any fuel additives used and when the additives are added to the fuel - all the variables and details are most helpful.
 
1 - 12 of 12 Posts
Top