Polaris ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Okay so I recently picked up a tb for $500. It needed some brake work new rear hubs and had idling problems. I have everything fixed minus the carb problems. The original Mikuni has all the screws totally stripped and unable to get them out. So I bought a replacement carburetor and put it on. Everything looks identical and it went right in. It fixed the idle perfectly but everything else was crap. Any sudden throttle will stall it out, but if I ease into it I can get to 3/4 throttle but then I can tell it’s running very rich. I’ve tried cleaning the carb adjusting the needle and checked the main jet is the same size as factory. Lost on where to go from here. I think it’s running rich but don’t know how to fix it. Any help appreciated.
 

·
Registered
Joined
·
2,352 Posts
In my repair manual it lists 2 different main jets for your machine dependent on model number of your engine.
Eng. mod. # ending in 06 or 07= main jet 145
Eng. mod.# ending in 08= main jet #120
needle setting for 06 or 07= 3rd clip
needle setting for 08=2nd clip
fuel screw setting 2 turns out on all.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
In my repair manual it lists 2 different main jets for your machine dependent on model number of your engine.
Eng. mod. # ending in 06 or 07= main jet 145
Eng. mod.# ending in 08= main jet #120
needle setting for 06 or 07= 3rd clip
needle setting for 08=2nd clip
fuel screw setting 2 turns out only all.
The original mikuni on mine calls for a 145 which is in the caltric carb. And how does adjusting the needle adjust rich/lean, as in which direction would I need to go for a leaner run.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
In my repair manual it lists 2 different main jets for your machine dependent on model number of your engine.
Eng. mod. # ending in 06 or 07= main jet 145
Eng. mod.# ending in 08= main jet #120
needle setting for 06 or 07= 3rd clip
needle setting for 08=2nd clip
fuel screw setting 2 turns out on all.
Okay, so I just changed out the 145 jet from the Caltric to the mikuni jet and it’s a lot better but at about 3/4 throttle it started running rich again.
 
1 - 4 of 4 Posts
Top