Polaris ATV Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
This machine starts and runs 1/4 throttle,idles great, but under load wont pull past 10 mph tops.BOGS DOWN TIL U LET OFF THROTTLE THEN IDLES FINE..no backfire or such just wont go... i changed and even added a second fuel filter. blew airbox out and ran great for 30 mins and back to same ol issue.. Any suggestions with this ghost issue. its in great shape for age hasnt had a ton of use.Also im getting fuel out the bottom overflow tube. the more i accelerate the more fuel comes out.i. i taped bowl several times to see if float was stuck no change. That carb looks fun to get to!!!!

any help would be greatly appreciated it is a 4 stroke motor automatic drive..beautiful reliable machine otherwise. i own honda and yamaha 4 strokes but this ones giving me buggy eyes!

Thanks guys
 

·
Registered
Joined
·
97 Posts
It's been awhile for this post...but...I would clean the carb. That has solved 90% of my problems. It is tricky to get to, but it will come out. I have had mine out so many times now that I have lost track! About a dozen times or so. With gas coming out the overflow, that's a good bet that the needle is stuck. Mine did that after leaving it in the Arizona heat all summer with an empty tank.
 

·
Premium Member
Joined
·
4,025 Posts
Sorry I missed this earlier. With the age, the problem is more likely the needle and seat are shot. Bad news is that Polaris is very proud of the parts...about 60 bucks. Good news is that you do not have to buy a kit of gaskets...there isn't one, and the seals on the carb are o-ring so as long as you don't tear them you do not need to replace them.
 
1 - 3 of 3 Posts
Top