Polaris ATV Forum banner

1 - 20 of 27 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hello I just bought a 2002 Polaris sportsman 700 twin and the speedometer is not working. As I understand that makes the awd not work? Everything on the cluster works except indicating what gear I’m in. My 4 wheel drive only works by holding down the reverse override button ( in high gear not backwards) does that mean someone rewired something to bypass the speedo? In any gear when I tap the speedo button it flashes the awd drive on the cluster screen and switches between the tach. Odo, and miles at the same time. I thought the Speedo button was only used in nuetral to switch between teach, odo, and miles.but mine does it in any gear and I have to hold it down to get 4 wheel drive
 

·
Premium Member
Joined
·
11,449 Posts
You need a new hall sensor.
 

·
Registered
Joined
·
10,828 Posts
From the service manual:

NOTE: If the gauge will not indicate what gear it is in and will not allow AWD operation, AWD can still be enabled by holding in the mode/override button.

To enter the diagnostics mode:
1. Turn the key switch off and wait 10 seconds.
2. Set the park brake and shift the transmission to neutral.
3. Hold the mode/reverse override button as you turn the key switch on. The initial screen displayed looks similar to Ill. 1 and is referring to the software version currently installed in your instrument cluster. This information is only briefly displayed.

Test the gear indicator switch - get the gear indication to work and AWD will enable
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
So it’s my gear indicator switch and not the hall sensor or could it be both. I still have miles on the display screen so I was leaning towards gear Switch. Any body else seen this issue
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
The Speedo doesn’t work I just bought it so I don’t know if the mileage is working but it does display it along with tach and hours
 

·
Registered
Joined
·
10,828 Posts
If the speedo does not indicate speed, the AWD will not work and the Hall sensor is probably bad. The display has to function properly for other functions to work. If the hour meter does not function, the problem is probably the display and if it can't read engine rpm to calculate hours of operation, the reverse limiter and the AWD will not work either. It may be a single component, or a combination of failures. Check the fault log and record (write down) the faults indicated.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #10
Thank you for all your help. My display DOES show everything including rpm the only thing it DOESNT show is the gear it’s in and the speedometer doesn’t work.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #11
Any other info I can give? Awd does work but only by holding the reverse override button. Could that mean it’s one or the other? Gear selector switch or hall sensor
 

·
Registered
Joined
·
14 Posts
I have a 2002 Polaris sportsman 700 twin awd not coming on I checked the plug at the switch brown and white I'm getting nothing unless I put brown with brown and white then I have power to the pins any thoughts on this
 

·
Registered
Joined
·
10,828 Posts
Brown is ground - brn/wht is ground through the speedometer - is your speedometer working?
 

·
Registered
Joined
·
10,828 Posts
AWD light gets it's ground from the speedometer pin #16 - try unplugging the speedo and plugging it back in - might just be a poor connection
145412
 
1 - 20 of 27 Posts
Top