Polaris ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello all,

I could really use some help on this one. I have a 2002 Polaris Sportsman 700 where the battery symbol and speedometer are flashing on the cluster. I used my machine to pull a fairly heavy drag on some baseball fields, after which these symptoms showed up. I was curious if I overworked it and heated an electrical component up? The ignition system has been changed to the Kokusan system from the Ducati (by a previous owner). The bike starts and runs, but will the battery will eventually die out. If I leave the fully charged battery hooked up overnight, it will be dead in the morning. I have had the battery tested, it is good. I have used a test light on all the connections I can find, and am not finding any draws. The battery volts increase to 13 - 14v when revved, so I do not think it is the voltage regulator. Has anyone else had anything like this that could offer another place to look? I am at a loss here. Thanks in advance!
 

·
Registered
Joined
·
9,999 Posts
It's a bad rec/reg or a stator winding shorted to ground - get it checked out before it causes something else to fail
 

·
Premium Member
Joined
·
10,580 Posts
also inspect the stator wires coming out of the case. there is a tendency for them to have rubbed through and possibly shorted or lose of a leg.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
also inspect the stator wires coming out of the case. there is a tendency for them to have rubbed through and possibly shorted or lose of a leg.
Thanks bp405. I looked at them coming off the stator itself and to the trigger, but not farther up the line. I will pull the covers and look at them tonight.
 

·
Premium Member
Joined
·
10,580 Posts
Thanks bp405. I looked at them coming off the stator itself and to the trigger, but not farther up the line. I will pull the covers and look at them tonight.
Correct just up to the connector coming out of the case. That's a potential wear spot that could lead to some issues!!
 
1 - 6 of 6 Posts
Top