Polaris ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Serviced cooling system and noticed fan was not coming on. Ordered replacement radiator fan sensor(tested original, would only close 30-50 degrees higher than specs.) and thermostat(original). Original stat had one weep hole,replacement has two. Not sure how to position in housing with the second weep hole. It must be an updated stat, but of course had no paperwork. Any guidance would be appreciated. Thanks.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Thanks Latebird, I will pull stat housing and turn stat 90 degrees to put the bleed holes at 3 & 9 o'clock. I currently have the bleed holes at 6 & 12 o'clock.
 

·
Registered
Joined
·
7,488 Posts
Sorry I couldn't respond earlier - 6 and 12 are the correct position - I was trying to infer the hole should be in a position to let the air through as the system fills - it will work in any position, but as a matter of habit, I install with the holes at the top.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Sorry I couldn't respond earlier - 6 and 12 are the correct position - I was trying to infer the hole should be in a position to let the air through as the system fills - it will work in any position, but as a matter of habit, I install with the holes at the top.
Sorry latebird, just noticed your reply. I will leave the stat where it's positioned. Selling to a friend I didn't want to install and cause issues.Thanks again.
 
1 - 5 of 5 Posts
Top