Polaris ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I am trying to find a replacement ecu for my Dad's 2003 Magnum 330. The OEM ECU is # 4010684 which seem to no longer exist. I have heard that ECU # 4010944 will work. Can anyone confirm this for me before my Dad spends another $200 trying to fix his quad? Is there anything that needs to be changed for the new ECU to work? Thanks for any help.
 

·
Registered
Joined
·
3 Posts
Fixed 2003 330 magnum 4x4. Replaced 4010684 with 4010944. Everything seemed to work fine. Overheat light went out but noticed awd did not engage. The fix we did was to geound the brown and white wire going to the ecu. This activated 4x4 not awd when switch was activated. Hopefully it does not cause any other problems. Good luck.
 

·
Registered
Joined
·
149 Posts
I see the 4010944 listed for all 330 models of that year under Polaris OEM part sellers. It's also listed for the 2004 model which just means they did an upgrade to the board hence the new part number.
 

·
Registered
Joined
·
3 Posts
I see the 4010944 listed for all 330 models of that year under Polaris OEM part sellers. It's also listed for the 2004 model which just means they did an upgrade to the board hence the new part number.
Hhhhh. While doing my research, in speaking with polaris dealers as well as polaris directly, i learned there are two letter designaters that go with the model. Mine has NO replacement. '04 models and some '03 models the 4010944 works. What i mentioned was my only option and it worked. When i originally purchased 4010944, i believed what i read and it was wrong.......
 

·
Registered
Joined
·
149 Posts
My reply is based on the thread initiator jrm2478. However by your reply it's clear that we need to offer as much info when looking for assistance. I guess we will wait and see if jrm2478 knows this tidbit. I'll dig out the manual for this unit and have a look for service dates and bulletins. What's your production date there scottb01?
 

·
Registered
Joined
·
3 Posts
My appologies. New to site. Got email on phone and thought you were responding to my post. I realize now, you responded to first post. As for my atv, there are two letter codes ie: s/b, a/b, etc. when polaris ran my vin, all they could do was say they had no answer for me. The 4010944 works in most but not all '03 330 4x4 models. I was told by polaris, 4010944 was a direct replacement for 4010697 and there was no replacement for 4010684, and they did not have any more 4010684 in stock. In case someone runs into same problem, i explained how we fixed my machine. Partzilla is also aware of issue and are the ones i putchased ecm from and who had me contact polaris directly. For anyone having same issue, i would contact polaris and have them run vin. They will let you know what part to purchase. Dont just rely on a quick web search.
 
1 - 6 of 6 Posts
Top