Polaris ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello, I am new to the forum. Lots of experts on this forum! I have had my 2003 Predator 500 for about 5 years w/o any problems besides the regular maintenance. Last year I had a cheap Batteries Plus brand battery that left me stranded twice on the trail. I replaced it with a YUASA YTX9-BS battery from the Polaris dealer, but after I connected the positive and then tried to connect the negative, it started sparking and melting the ground terminal. I thought I may have overcharged it, so I bought another battery, but had the same results. I don't think it is anything major because it was working fine with the cheap battery, besides not starting after a long ride. Not sure if it may be a starter/solenoid issue? Thanks for any advice you can give me.
 

·
Registered
Joined
·
2,980 Posts
Hello, I am new to the forum. Lots of experts on this forum! I have had my 2003 Predator 500 for about 5 years w/o any problems besides the regular maintenance. Last year I had a cheap Batteries Plus brand battery that left me stranded twice on the trail. I replaced it with a YUASA YTX9-BS battery from the Polaris dealer, but after I connected the positive and then tried to connect the negative, it started sparking and melting the ground terminal. I thought I may have overcharged it, so I bought another battery, but had the same results. I don't think it is anything major because it was working fine with the cheap battery, besides not starting after a long ride. Not sure if it may be a starter/solenoid issue? Thanks for any advice you can give me.
Sounds like you're hooking it up backwards. Check and make sure the pos and neg poles are in the same physical place as on the old battery. Sometimes the batteries have them reversed for some strange reason, and if so you can go pos to neg and vice versa. If that's not the case then it sounds like a short somewhere....and that's an undiagnosable problem on a forum. Could be anywhere
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks, didn't realize there were two negative terminals. I knew it was something minor. Really feel like an idiot now though!!:chairfall:
 
1 - 4 of 4 Posts
Top