Polaris ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Thanks for all of the help so far, Ive learned a ton from this site and its members.
Only a few problems left to deal with.

My left front wheel is wobbling. I took the wheel off and the hub doesn't seem to have any play. I've also switched the left and right rim to make sure its not a bent rim or something.
Im guessing the whole hub assembly is warped but am wondering if there's any way to know for sure or if there's something else that I should check first before spending a small fortune on a new hub. Im hoping it something else because the hub assembly looks pretty expensive.

Thanks!
 

·
Registered
Joined
·
1,891 Posts
did you check ball joints..tie rod ends.....bushings.....did you spin the tire to see if its running true...also check wheel bearing...check the front with tire on...grab it and move in different directions...up an down..side ways...see if you can make it wobble and see whats causing it...do it jacked up
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
I've checked the wheel with it jacked up. There isn't any play in it. I can see it wobble when I spin the wheel. And i've switched the left and right wheels and its still the left side that wobbles.Not sure how to check the ball joints but ill start researching it now.Thanks!
 

·
Registered
Joined
·
2,352 Posts
I don't see how the front hub could've gotten bent, unless it fell off the back of a pickup or rolled down a hill several times.
Best look at the wheel bearings.
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board!
 
1 - 5 of 5 Posts
Top