Polaris ATV Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
i just bought a sportsman 500 i tryed searchinng couldnt find anything so i thought id post my speedo dosnt work and my awd switch dosnt work the atv is stuck in 4x4 im pretty sure and my override switch only works sometime not sure if its bad ground ive been told this is a comon problem on these atvs was wondering what the fastest and easyest fix is thanks
 

·
Registered
Joined
·
128 Posts
im going through roughly the same thing and from what i understand if the speed sensor isnt working it will not read speed and will lock the 4wd in. im not sure but thats what im thinking.my speedo was smashed and previous owner had wired a switch in so the 4x4 would work. i ordered a new speedo and installed it and removed switch ,now 4x4 wont unlock and no needle movement when driving.
 

·
Registered
Joined
·
1,891 Posts
its the hall effect sensor that relays the speed to the speedo....its the smaller plug on the speedo.....the sensor is located on right wheel...by the brake disk...
 

·
Registered
Joined
·
2,412 Posts
Change your hall sensor. almost all speedo issues are cured with this. 4x4 runs through speedo so it needs to work to have 4wd.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
ya the 4x4 works i just try and turn it off and dosnt seem to unlock and my speedo dosnt work
 

·
Registered
Joined
·
2,412 Posts
Dirty fluid can cause it to lock up. Try putting it into reverse and see if it unbinds.
 

·
Registered
Joined
·
128 Posts
mine is different my light goes on and off but 4x4 stays locked in. that cable is 72 bucks think ill just deal with not having a speedo.
 

·
Registered
Joined
·
1 Posts
I have a late 2004 polaris sportsman 500 ho , the speedo works the switch when switched to awd it shows on the display and goes off but will not disengage? Any advice
 
1 - 10 of 10 Posts
Top