Polaris ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I posted this over on the model specific forum but thought I might generate a response here... I have a 2004 Sportsman 500 ho, it looks like it was hardly used by the previous owner. I was told it had 620 miles, however I cant find the mileage log on the instrument panel. I have held the yellow button and find where it shows "MP" but there are no other numbers. I must be looking or doing something wrong, any help would be greatly appreciated.
 

·
Registered
Joined
·
7,992 Posts
Instrument Cluster Rider Information Center
The rider information center has 4 standard modes:
Mode 1 - Odometer
Mode 2 - Tripmeter
Mode 3 - Total Service Hours
Mode 4 - Tachometer
The reverse override button on the left handlebar is also the mode button. NOTE: If using the mode button to program the rider information center, or to toggle through the options, the machine cannot be in reverse.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Instrument Cluster Rider Information Center
The rider information center has 4 standard modes:
Mode 1 - Odometer
Mode 2 - Tripmeter
Mode 3 - Total Service Hours
Mode 4 - Tachometer
The reverse override button on the left handlebar is also the mode button. NOTE: If using the mode button to program the rider information center, or to toggle through the options, the machine cannot be in reverse.
I must be doing something wrong, as I am following those steps but only see MP there is no number indicating miles.
 
1 - 4 of 4 Posts
Top