Polaris ATV Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Last weekend while out having fun ended up tipping ATV on its side. Before this happened the machine was running well but once we tipped it back upright the machine will turn over and fire up but will backfire through air cleaned whwn gas it applied. Machine will idle for 30 seconds and die but then will fire right up. Anyone have troubleshooting advice as to what to do to fix machine.
 

·
Registered
Joined
·
5,049 Posts
Try purging air from the fuel rail - release the fuel pressure from the rail where the pressure gauge would be connected - once bled, cycle the fuel pump on till it shuts off, then turn the key off and back on to cycle the pump on and off again - repeat 4 or 5 times and try running it again - if that doesn't work, check the fuel pressure - the pump may have been damaged if it ran dry while tipped.
 

·
Premium Member
Joined
·
7,485 Posts
Chk your oil level and you may need to remove the spark plugs and turn the machine over to "blow" out the combustion chamber.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
Thanks Latebird. Gave it a try and still not wanting to run. Will fire up and idle but popping and sputtering
Will have to get gauge to check pressure
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
Purge fuel rail and blew out chamber and still not running well. Will fire and idle for a while but any gas causes it to sputter and die
 

·
Premium Member
Joined
·
7,485 Posts
Chk for any codes.
 

·
Registered
Joined
·
5,049 Posts
Throttle

Purge fuel rail and blew out chamber and still not running well. Will fire and idle for a while but any gas causes it to sputter and die
When you give it air by opening the throttle, the fuel system is not doing it's job and supplying the increased air flow with the proper amount of fuel - the trick is to figure if it's supplying too much or too little fuel
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
Ok guys. Engine temperature lamp fault! Would that actually cause running issue with the machine. Where or what can be done to correct other than disconnect battery and reset code?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #11
Still looking for suggestion. Fuel pressure is perfect, fault has been reset, noticed that fan never turns on however. Changed temp sensor, and the thing still sputters and dies
 

·
Registered
Joined
·
5,049 Posts
What's wrong with taking it to the dealer and having them (he or she or it) run the diagnostics? You bought it with EFI and you knew some things would require them to perform the service.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #13
What's wrong with taking it to the dealer and having them (he or she or it) run the diagnostics? You bought it with EFI and you knew some things would require them to perform the service.
Other than distance to dealership as local one closed down 5 years ago
 
1 - 15 of 15 Posts
Top