Polaris ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2005 Polais 500 H.O. that we just replaced the voltage regulator with a new one from Polaris and it is still overcharging. The reglulator is the second one installed on this unit, the first one burnt up inside after riding, due to not noticing the overcharge was still there after replacing the regualtor. I have been told the unit is not in the recall of ecu's from Polaris.
We checked the stator for ohm's resistance and it checked out ok. Have not checked it for output as need spec's. ANY IDEA's?
 

·
Registered
Joined
·
601 Posts
Hey Ken, i have a 2009 myself so my service manual won't help...but i have excess to a 2001 Sportsman 400&500Ho manual that might help...so if you want, i can send it in a file...just drop me a email....Muddie49:joint:
But it sounds like the stator has gone south..((have you checked the battery?)
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Polaris 500 overcharge

Hey Muddie49,
Yes we replaced the battery with a new one as it was toasted from overcharge. The stator ohm's check out but need to look at stator output.
Do you have stator output for an 02 in your manual?
 

·
Registered
Joined
·
50 Posts
I bought the manual(genuine polaris shop manual) in pdf format on-line this past Saturday for $5.50 USD. Well worth it. Just google year make and model then narrow to shopping. Paid via paypal took my proof of purchase to staples and for $20 they printed and bound it for me form my usb stick.(of course printing is optional lol)

Now to answer your question 7amps ac at idle. The manual has a full break down of all possible tests.

Best Regards
James
 
1 - 7 of 7 Posts
Top