Polaris ATV Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Starts and idles fine but as soon as I give it throttle, it wants to stall(in any gear). Changing plug and oil tomorrow. A buddy said to drain float bowl in case of water buildup. Did this with no result. Problem started when I was plowing snow down hill and using ABS to some extent. At first ran fine under load uphill. Problem has gradually gotten worse to the point where I can't use it atall. Please advise
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Pulled plug and it is as black as night and reaks of fuel. I think it is a carb problem. Could the jet needle be part of the problem ? I am new at this and don't want to screw anything up. Please advise
 

·
Registered
Joined
·
4,243 Posts
how much slack is in throttle cable? should only be 1/8 inch at thumb throttle, adjustment is in cable about 4 inches from thumb throttle, rubber boot that pulls back,adjustment underneath.
 

·
Registered
Joined
·
2,412 Posts
Sounds like you have a fuel issue. Did you find any water? If you did then you need to change that if it was a paper one. I would give the carb a really good cleaning. Run some Seafoam through it and clean it well.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #10 ·
Thanks everyone for all your help, the quad is now running. The clip came off the needle inside the carb diaphragm, I just repaired it but maybe I should buy a new clip or replace the whole assembly. I have a new problem now, my winch will only come "in" but not "out". I wonder if I did something when I had the quad apart for the carb problem. Any suggestions? At least I caught up on some of the snow removal just a little slower. Thanks again for everyone's help
 
1 - 10 of 10 Posts
Top