Polaris ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
I am a newbie at these ATV's and bought this 2006 Sportsman which is in very nice condition, with quite a few accessories. Anyway back to my question, I have a 60 in. Plow hooked to it and seem to be having an issue with the Winch. Seem when I let the line out no problem, it's when I use the in toggle I get a click and have to keep depressing it about 2-3 times before it draws the cable back in. This is with about 2 inches of slack when out if I keep it taut it draws it back no issues.

What am I or should I look for here to correct this. Also is there a device that will eliminate this to letting the cable out just far enough to let the plow touch the surface? I seen that some of the new ones have a puck of some sort that cuts the power when bringing the cable back in.
 

·
Registered
Joined
·
5,753 Posts
Sounds like the winch contactor is going out. Nothing to set letout, but there are automatic stop fairleads you can get to stop it from pulling in to tight.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
This Winch Contactor you mention is there a part that I can get to solve the issue? I knew about the automatic stop when reeling in the cable, as I saw it at a dealership, but thank you for the info on that.

I'm just now concerned about this contactor you mentioned, and it's only on the inbound.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #5
Thank you for your reply, now all I have to do is to find out which Winch I have on my Machine. What the size is and locate this contactor. Excuse me for sounding rather naive on this, but as I stated I am very new at these ATV's.
 

·
Registered
Joined
·
486 Posts
Contactors are fairly universal , the one from ebay will work fine on your machine . It should be mounted close to your battery .
 
1 - 6 of 6 Posts
Top