Polaris ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 07 outlaw 525, I just picked up last week. Everything was working fine. Parked it - few days ago. Went to ride it today and the clutch was stuck fully out. I grab the clutch as hard as possible to bring it in and it won’t budge. I’ve messed with the red adjustment and that won’t do anything either. Any ideas what is going on? Thank you.
 

·
Premium Member
Joined
·
4,025 Posts
Are you saying you can't move the lever to disengage the clutch? Look for something that is binding up the movement of the lever at the handlebar and on the transmission first. Then disconnect the cable from the bottom and try to move the lever. If that works then your issue is inside. If not then probably cable or at the lever
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Are you saying you can't move the lever to disengage the clutch? Look for something that is binding up the movement of the lever at the handlebar and on the transmission first. Then disconnect the cable from the bottom and try to move the lever. If that works then your issue is inside. If not then probably cable or at the lever
Yes, the clutch lever is stuck all the way out. I’ll go give that a shot and see if that works. Thank you!
 

·
Registered
Joined
·
58 Posts
its a hydraulic clutch on the 525.. look for a leak... could be air in system (low dot or leak).. but sounds like a master or slave..
Will it start in neutral? Does it start at all?? 525 right? the only cable on the 525 is the revers cable.
if you cant pull the clutch lever and its just stuck i would say master. if the one way ball sticks it will stack pressure (master). if the clutch lever is easy and has play but no clutch its a leak.
 
1 - 4 of 4 Posts
Top