Polaris ATV Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I am hoping someone can help me with a problem I am having with my 2007 500 HO EFI. My quad was sitting around since February and maybe only started it once since then. The battery was dead so I hooked it up to my battery tender for 2 days and the light reads green which means it is charged.
Well when I turn the key it just makes a clicking noise. The engine does not even try to turn over (just clicks). The lights on the display do not light up and the headlights on the quad do not light up either. I checked both the positive and negative cables to the battery and they are both tight. Could the battery possibly even though reading fully charged based on the battery tender not be strong enough to turn over starter? Thanks for any help that comes my way.
 

·
Registered
Joined
·
226 Posts
when was the last time a new battery was put in it? With efi u have to have to have everything to do anything lol. The only reason pull starts are there is that if the starter goes out. U must have enough voltage from bat !
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board!:med:
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
Battery was changed 2 years ago. I tried to pull start it many times and no luck will not turn over. Does not even seem to fire.
 

·
Registered
Joined
·
862 Posts
Battery is probably shot, as soon as you put a load on it the voltage drops out. If you have a volt meter put it to the battery and hit the starter, it will drop. Battery tenders arnt normally meant to charge a battery, they are float chargers which maintain a full charge voltage at a very low current, it would probably take a week to charge it if it would at all. Do you have a normal charger that will put out a few amps? That might help some. With the efi systems if the battery is bad it won't have the power to drive the fule pump or fire the injector, some time you can't jump bad batteries either.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
Put brand new battery in the atv and no different. It clicks and does not even try to fire up. No lights go on the instrument cluster and the headlight will not turn on.. Check all the connections too. Help
 

·
Registered
Joined
·
226 Posts
did u charge the new battery? If its a battery u have to put the acid in yourself it must be charged. :)
 

·
Registered
Joined
·
12 Posts
Discussion Starter #8
Acid was put in by dealer and sealed. I then put it on battery tender for 12 hours to charge. Put it back in and connected it.. And problems in previous message occurred.
 

·
Registered
Joined
·
1,360 Posts
PDM?

Sean
 

·
Registered
Joined
·
12 Posts
Discussion Starter #13
Took the front storage box off and do not see a fuse a box. Are there fuses somewhere else? Behind the radiator there is some sort of unit with many wires leading into and out of it. Is that the PDM? I also checked the battery have 13.2 coming off the battery so battery is good.

To recount my end... I changed the battery... charged it ...reads 13.2.. Check the battery connections all good. Check the connections to what I believe is the selinod Good.. STILL no lights.. no instrument lights.. Does not even try to turn over... JUST hums clicks.... hums clicks!!!!

I am so stuck ready to take it to the dealer and bite the bullet on the repair cost.
 

·
Registered
Joined
·
46 Posts
Not sure about the 2007 but my 2009 has the fuse block (4 fuses) right under the headlight pod and can be accessed from the front storage box.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #15
I took the cover off of the front steering wheel headlight. Looked around and under the headlamp and there are no fuses that I can see.
 

·
Registered
Joined
·
226 Posts
There is no fuse block on a 2007. It is internal from the PDM
 

·
Registered
Joined
·
1,360 Posts
PDM is also called a SSCB in the maintenance guide. It contains self resettable solid state circuit breakers. On my 2006 the PDM (also called ECM...so it has three names) also controls the fan, battery charging..and I cant remember what else. Should be located up top in front of the radiator. I took the back off mine and could see water damage.

Sean
 

·
Registered
Joined
·
12 Posts
Discussion Starter #20
What is the difference between the PDM and the ECM? If I have a new battery fully charged (I check) and still no power to lights, instrument cluster. Can not pull start it... Turn the key just hums... clicks... pauses... hums... clicks... Clicking seems to be coming from closer to the starter on top of engine, NOT by the battery near the selinod (spelling).. So with that being said ECM or PD???
 
1 - 20 of 25 Posts
Top