Polaris ATV Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hey everybody,
I'm new to the forum and have looked for answers through other searches here – unfortunately has not been able to figure out which is the next step or problem.

2008 Polaris 500 EFI – no start:
  • Had always Started and run very well – Until was parked from the end of winter to summer – Would not start and discovered tank was empty
  • Will fire occasionally when cranking
  • Removed fuel filter and will surge small amount of fuel when key is activated

Next ideas please?
Thank you for your helpful consideration of my question.
Craig
 

·
Premium Member
2008 800 ho efi, 2019 850 SP premium
Joined
·
15,182 Posts
Welcome to the forum
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
Is the pump designed to build line pressure when the key is first activated or just a short purge?
How to check fuel pressure and will the pump cycle with no fuel line connected?
Thanks, Craig
 

·
Super Moderator
Joined
·
16,283 Posts
Fuel pump runs for about 3 seconds when the key switch is cycled on. You have to T into the fuel line going to the injector. You can borrow or rent a fuel pressure test kit at most any auto parts store.
 

·
Registered
Joined
·
13 Posts
take it it is the fuel tank to what you are referring to How much gas was in the tank & do you use fuel stabilizer THIS IS A MUST to avoid fuel related problems
if there was a considerable amount of fuel in the tank? it went somewhere?? & you better check your oil level might have bled into the crankcase also smell the oil see if it smell's like gasoline
sounds like possible fuel pump but better to test & not guess no need to throw parts at it & hope you throw the right one at it good luck! :unsure: (y) 🤞
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #12 ·
Thank you for following up with me on this - it is very important as I bought this after a bad accident and absolutely need it to get up and down the hill to our house with snow and ice.
Gotten very cold with no insulated or heat in garage - I will check tomorrow or today filling with fuel and cycling again.
Pump does cycle with key like supposes to.
Never used stabilzer - new to atv's - makes sense especially with EFI - What brand do you recommend possibly Seafoam?
Filter blows air freely by blowing through
I have not tried starting fluid
Thanks, Craig
 
1 - 13 of 13 Posts
Top