Polaris ATV Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a sportsman 850 xp. We had a couple issues this last weekend. While on throttle no issues, when coming to a stop it stalled out. It immediately restarted. This happened twice. It has 120hrs - I am going to replace the spark plugs. Is there anything else I should look at? Any other tune up related maintenance I should be doing?

Thanks
 

·
Registered
Joined
·
192 Posts
Welcome to the site!

Have you checked your air filter?
 

·
Registered
Joined
·
153 Posts
Have you checked for play in the throttle cable? I believe its around an 1/8 of an inch free play. It should be in your manual. This is fairly common, when you have to much free play and let off the throttle the machine will quit.
 

·
Registered
Joined
·
4,629 Posts
Sounds like classic ETC adjustment, definitely the place to start. A little oil residue is ok but actual oil is a problem.


Rather be riding, instead I'm using Tapatalk
 

·
Registered
Joined
·
13 Posts
My 850 XP does almost the same thing that you described, it will die at a steady throttle position and most of the time restart, cold starting 55 degrees it will not keep running, it has been to the dealer 3 times without any repair or improvment, now the dealer says that there was oil in the airbox, I checked this myself before bringing it to the dealer and there was the slightest of residue in the bottom of the airbox, none had gone through the air filter it still looks like new and the engine has not ever smoked or looked like it was burning oil so I doubt if this is the cure for the problem I am having. I can not make it to the atv trail without it stalling out, it has used three gallons of fuel to go 20 miles no 4X4 no mud no hilles. I believe it is a fuel enrichment problem temperature sensor sending the wrong signal to the ecm ?? The check engine light does not show any codes to diagnose the problem
 

·
Registered
Joined
·
373 Posts
I have a sportsman 850 xp. We had a couple issues this last weekend. While on throttle no issues, when coming to a stop it stalled out. It immediately restarted. This happened twice. It has 120hrs - I am going to replace the spark plugs. Is there anything else I should look at? Any other tune up related maintenance I should be doing?

Thanks
I had the same issue with my throttle adjustment at the thumb throttle. There is an explanation of how to properly adjust it in the operators manual. It's somewhere around 2-4mm if I remember right - very hard to measure with measuring tape - then I decided to try my metric allen wrenchs as a feeler gauge and all went smoothly from there..
 
1 - 8 of 8 Posts
Top