Polaris ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey guys! I'm new to the forum long time Rider I've got an issue with my sportsman I purchased about two months ago it has been running perfect since day one until three days ago I rode it to the store about 2 miles away from the house filled it full of 93 octane fuel and left the store about a quarter of a mile away from the store I lost all power started spitter in sputtering and backfiring I lost all power and in order for it to stay idling I had to pull the choke out since that time it will not start without starting fluid and choke all the way on, and will not Idol unless choke is all the way on? Due to the timing I assumed it was bad fuel so I have drain the fuel And ran 50-50 mix seafoam and fuel trying to clean the carburetor I have blown out the bowl through the vent tube with pressurized air. But my problem is still there I am about to pull my hair out I don't know what to do somebody please leave me in the right direction???
 

·
Registered
Joined
·
2,352 Posts
You may have to remove the carb. and clean the pilot jet(small one, looks like a lil missile-skinny straight blade screwdriver for removal).
It happens.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
I took the carb off!

I took the carb off last night and am planning on stopping by my local hardware store and getting the carburetor cleaner and everything needed to clean it. I noticed that the bottom of the carburetor one of the screws that hold the bowl is stripped out pretty bad apparently the previous owner did some work himself I don't know if I'll be able to get it free or have to drill it out any secrets anyone knows? Thanks for the replies guys I appreciate it.
 
1 - 4 of 4 Posts
Top