Polaris ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I have a 2012 550 eps touring that failed to start on 3 separate occasions. the first 2 times I turned on the key and the fuel pump would not activate and thus would not start. each time after about 2 hours of sitting the machine would go back to normal and start. the third time I had the same problem with the pump not activating and also lost power to my grip warmers and winch. the dash also showed a problem with the eps. I trailered the machine home and this morning everything is back to normal. the problems all happened after riding to my ice shack and sitting for a few hours. any ideas?
 

·
Registered
Joined
·
8 Posts
I had the same problem when I was out in Wyoming hunting. It rained and froze and temps got low ( 12 degrees). I turn the key and hear a click noise and thats it. The sun came out and it got above freezing and it started right up. I thought it was the battery but even jumping it, it would not start. When I got home, I took it to a car wash and blew the mud off it. It was very cold that day. After hosing it off and trailering it home, it did the same thing. I think there is some electrical connections under the front rack that is getting water in it causing it to freeze and not start. I asked the dealer about it and they told me good luck because it wouldn't be covered under warranty. Getting water somewhere is not a warranty issue. It is currently in the shop getting new A-arm bushings. Once it gets back I will investigate and give an update.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
same thing happened

out plowing today. shut the machine off to do some hand work then wouldn't start again. what might the other 15.5% be?
 
1 - 5 of 5 Posts
Top