Polaris ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I'm having trouble with my 2012 550xp two up. When the bike comes under strain either pulling someone out of the mud or slowly crawling over a larger obstacle the bike will go into safe mode and I will loose power steering and the engine light and temp light will come on. If I stop and put the bike in park shut it off for 10 sec then start again it will clear itself . I've heard that some of these bike's had a wiring issue in that the harness Is to short and maybe I have a plug that is slightly coming apart when the bike torqued up. I was wondering if anyone else had this problem and if so how was it fixed. I'm to the point now I don't trust the bike to go on a long ride or a mud run because I don't know if the next time I shut it off if it's Going to reset or stay in safe mode or if I will be able to pull someone out if they get stuck. Any suggestions would be really appreciated
 

·
Registered
Joined
·
1,968 Posts
If you aren't getting any check engine codes I would spend some time examining electrical connections and apply dielectric grease to all of them.
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board.
 

·
Registered
Joined
·
1,048 Posts
You need to reproduce the condition again but this time before shutting off, see what code is bring set. That will steer you in the right direction. If you key off, it will clear the code if the condition is no longer there when you go to restart.

Matk
 
1 - 4 of 4 Posts
Top