Polaris ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
2012 Polaris sportsman 800 ELECTRIC issue! Speedo comes up with key on, I have lights but fuel pump does not come on, I have 12 volts going to the starter solenoid but it will not crank. The ground wire from the solenoid goes back to the ECM. Would this be signs of a bad ECM??
 

·
Registered
Joined
·
6,585 Posts
From the service manual
137305

The brown wire is ground - the wht/red wire has 12v when the key is turned to start - does the wht/red wire have 12v when the key is turned to the start position? Connect the brown wire at the solenoid to a ground and see if it will start.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Yes it’ll Turn over using the key if I ground the brown wire. It just won’t turnover when the ground is ran back to the ECM as normal. And I have no power at the fuel pump. I believe I’ve read that the ECM tells the solenoid when to ground when the key is turned over and tells the fuel pump to pre charge when the key is turned on but I’m not sure. Just wanted some more input before I bought a new ECM
 

·
Registered
Joined
·
6,585 Posts
To verify the ECU has failed, it needs to go to a dealer and have the diagnostics run on it - or if you are a gambler, buy an ECU for $515 and see if replacing it solves the problem.
 

·
Premium Member
Joined
·
8,154 Posts
I'd chk fuses and relays. Also the terminals they plug into. Also chk the wiring coming up from the frame to the pod. They have a tendency to get damaged from twisting.
 
1 - 6 of 6 Posts
Top