Polaris ATV Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Any reported problems with pressure relief valve? My atv has about 630 miles on it and recently got it back from the dealer after about 3 months. It literally rounded out the camshaft and even dished out a couple of the lifters. Being out of warranty Polaris did cover the parts out of good faith. My dealers service said Polaris has known of this issue but not enough to warrant a recall. This is my 1st atv which is mainly used around my acreage. Anyone else have this problem? I have read on the early 2000 models it was an issue. Any input greatly appreciated... Thanks
 

·
Registered
2007 500x2 le
Joined
·
850 Posts
Haven't heard to much of it on the 10 and up 800 I hope mine doestn do that ! Did it give u any signs before it happened !? Also do u regularly change your oil?? Just curious not saying that was the problem
 

·
Registered
Joined
·
978 Posts
oh man i hope mine doesnt either. I never heard of this problem before? Any ideas how it happened? Any signs leading up to it?
I got a 13 800 efi wondering if they worked this out by then
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Yes I had the oil changed at the 250 mile break in period. The dealer has done all the service on it. I used it to snow plow my driveway which at most was 5-6 inches at a time and rarely had it faster than 20mph being it was winter and when plowing kept it around 10mph. When spring came whenever I hit around 35mph it had no power and would seem like it was cutting out. I think I happen to be one of the very unlucky few to have this happen to. I bought a Polaris because everyone I know who has one has been very happy with it. I'm not going to judge them on this one incident. I will see how it does after a few more years then come to my own conclusion. I was just wondering if anyone else had this problem.
 

·
Premium Member
Joined
·
10,362 Posts
Nope never heard of any typical problems with the 800. Here and there I have read of problems but like I said they were random failures. The only thing I can recall reading maybe a handful of times was oil consumption.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
Sorry about the break in period mistake. The manual I think says 10 hours or after 2 full tanks of gas for the break in period. I had not quite 225 miles on it at the time.
 

·
Registered
Joined
·
978 Posts
yea the 10 hr break is right. 250 miles seems pretty high to change out your oil on the break in. I changed mine at 10 hrs 120 miles. But your riding cld be different then mine where you can put 200 plus miles in 10 hrs. Always hate to hear about a fellow rider having problems
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
Well I live out in the country so I take my niece and nephew for long rides. They get a kick out of it. Also my main purpose for getting it was sick of snow blowing my driveway not to mention my dad is disabled so he uses it to get around the place. I've never taken it out hill climbing and through any type of water. Mainly seen gravel roads and farmland when nothing has been planted yet. As far as speed I rarely push it past 35 mph and thats if on it alone. Thanks for everyones reply.
 

·
Registered
Joined
·
264 Posts
My 2012 800 also rounded out the camshaft at 520 miles. I'm betting that my dealer won't cover anything. I'll bring in the parts to them to see what they say. My first oil change was at 24 miles.
 
1 - 10 of 10 Posts
Top