Polaris ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi everyone I am a new member to the forum and could use some help. I have a 2013 850 xp that won't start. I was out yesterday riding all day stopped for lunch and dinner and bike ran and started all day with out a hiccup even when I went to park it. Went out today to go out for another ride and notice bike was sounding rough when I was turning it over. Started to run but after it started to turn it backfired so loud it sounded like a gun shot. The engine light flashed twice out of the couple times I tried starting it but didn't stay on. The battery was week from the sudden drop in temperature last night but not sure if a weak battery would cause this. And where I could start? Thanks guys
 

·
Registered
Joined
·
93 Posts
Not sure it would be the same problem but my buddies Scrambler 850 did the same thing to him. The only way he could get his to start was if he was giving it some throttle at the same time. It turned out that his timing gear had slipped and the bike is currently in the shop for a rebuild. Hopefully this isn't what happened to yours but just figured I would throw it out there because his was a similar situation.
 

·
Registered
Joined
·
5,753 Posts
Try putting a good charge on the battery and see if that's all it is. Could also be a fouled plug with the temp drop and a cold engine. They are good for that.
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Hey guys just wanted to say thanks for the help I started at my plugs and they were fouled beyond belief swapped them out and runs like a top
 
1 - 5 of 5 Posts
Top