Polaris ATV Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
Help out there my fellow riders. Does anyone else have a problem with the seat on atv not sitting properly? Just bought my 570 and like it so far but the seat don't ride right. It slides off rubber stopper and allows plastic to sit weird on heat shield for muffler. They have replace red seat once, but after riding this weekend this one is messed up also. Seems lime a manufacturing g defect to me.i will be talking to Polaris dealer again Monday. Any input would be great.
 

·
Registered
Joined
·
3,096 Posts
I have never heard of this issue before with the 570......
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board!
 

·
Registered
Joined
·
4,243 Posts
Make them get it right, something is not adjusted right or its missing parts. Compare to another one at dealer.
 

·
Registered
Joined
·
51 Posts
I have only had mine for a week but no seat issues thus far!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
It's located on rt side where it rides on the heat shield for muffler. It vibrates extremely load when riding and is either melting or rubbing seat stopper.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
Take your seat off and look at the four resting areas and see if they all look good. Rt side of mine either melting or rubbed off. Making very load clattering noise.
 

·
Registered
Joined
·
4 Posts
My seat is messed up too. Huge gap at front of seat. I took the seat off and there doesn't seem to be anything melted or otherwise damaged.
 

·
Registered
Joined
·
1,010 Posts
Are these tourings or 1-ups?.. There were some posts earlier about the seats on the tourings not fitting right.. If your machines are 1-ups than these are the 1st reports of any issues with the seats as far as I know..
 

·
Registered
Joined
·
815 Posts
It is happening to 1 up owners too it sounds.
 

·
Registered
Joined
·
1,010 Posts
It is happening to 1 up owners too it sounds.
whtrapta.. you posted about this earlier with your touring didn't you?.. what was the fix if there was one?.. This is one of those "new model" issues that's gonna drive everyone nuts no doubt.. I take delivery of mine on april 17th and I'll be chatting about this with the dealer.. To all of the others.. If you have this issue.. Get in front of your dealer.. It takes multiple voices to demonstrate to any manufacturer that a fix is required..
 
1 - 12 of 12 Posts
Top