Polaris ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I just purchased a 14 sportsman 570EFI touring last month. Right off the bat I noticed the seat did not appear to be secured tightly. This model does not have a latch for the seat, instead having two guides at the front and two plastic pegs at the back. The seat is by no means secured. When travelling down a logging road last weekend I stood and both the main seat and 2-up seat flew off the machine after only hitting one bump.

I called the dealership who said that the seat shouldn't have done that (obviously) and told me to bring it in and they would warranty whatever is wrong.

I just received a call back from the dealership telling me not to bother bringing the ATV in as there is no current fix but "Polaris is aware of the issue".

Has anyone else had this problem? Is there a solution? The ATV in my opinion is not safe in it's current state and I am hesitant even riding it. d
 

·
Registered
Joined
·
1,968 Posts
Interesting... it sounds like a similar setup to what is on my 550 but that seat is very secure. I wasn't sure when I first got it as I was used to the latch on my 700 but seems to work well enough.
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board!
 

·
Registered
Joined
·
1 Posts
Same problem here. What I discovered after my first 120 mile ride, was that the rear passenger support of the seat, has holes to be bolted to the frame. Mine was not, thus without a passenger the seat would never really lock in. The front tangs do a poor job as well and the seat posts are not really long enough to go further through the frame. Going to the dealer and first service tomorrow. The seat sliding all over the place did some real damage to the surrounding plastic.
 
1 - 4 of 4 Posts
Top