Polaris ATV Forum banner

1 - 6 of 6 Posts

·
Registered
2018 Polaris Sportsman 850
Joined
·
4 Posts
Discussion Starter #1
New 2018 850. 100 miles on it. Been on 2 rides Most miles have been put on it just riding the kids around the yard. It has not been hurt. Run hot on a ride months ago and cooled to normal with the fan. Washed everything out good when I got home. Have used it since with no lights on as well as the fan running like its supposed to. Cranked it a week ago and the over heat light came on and wont go off.Rode it to get the temp up and the fan came on at 196 and cooled it down then cut off. The light is still on. Then this weekend the turtle light came on and it wont go off. Ive tried getting a code from the display but it doesnt show anything. Ive unhooked the battery for minutes, hours and then over night. The lights are still on. Ive read the manual, googled, youtube'd and now Im here.
The local Polaris shop is backed up 3 months before they can even look at it.
Anyone got any ideas ?
 

·
Registered
Joined
·
2 Posts
I have the same bike and mine did that too around 100 miles, I had only ridden about 5 miles when that happened to me. I turned the bike off, let it cool down, took the rad cap off and found that it had air in the system. I let it idle for 10 minutes with the cap off, bubble came up and now have a about 1200 miles on it and not 1 more problem.
 

·
Premium Member
Joined
·
9,727 Posts
so elevate the front remove the rad cap. burb the system and add coolant. remove the battery cables let it sit for 30 min and re-connect. should be good to go!!
 

·
Registered
2018 Polaris Sportsman 850
Joined
·
4 Posts
Discussion Starter #4
I have the same bike and mine did that too around 100 miles, I had only ridden about 5 miles when that happened to me. I turned the bike off, let it cool down, took the rad cap off and found that it had air in the system. I let it idle for 10 minutes with the cap off, bubble came up and now have a about 1200 miles on it and not 1 more problem.
Thank you so much. Going home to try this now!
 

·
Registered
2018 Polaris Sportsman 850
Joined
·
4 Posts
Discussion Starter #6
UPDATE: did everything suggested on this forum. There was air in the lines. I think i got that taken care of. However, the lights are still on. No loss of power and the fan is kicking on at 196 and cooling down as it should be. I called the dealership I got the bike from..they say to cut those lights of it has to be hooked to Polaris software.
 
1 - 6 of 6 Posts
Top