Polaris ATV Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I’ve had my 570 for about a year. And all of a sudden tonight the engine light came on. It seems like it’s running fine. I don’t see codes or anything to say what’s wrong. Does anyone have suggestions before I call the dealer?
 

·
Registered
Joined
·
40 Posts
My 2018 just recently did that. I shut it off, topped it off and drove it about 1/4 mile. Light went off. No codes were shown.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
It’s completely full of fuel but I read that it could be the EFI and could damage the engine so I parked it. Pretty frustrating since it has like 50 hours on it
 

·
Registered
Joined
·
74 Posts
my 2018 also has the check engine light on and off its code 520194 for throttle safety resistors not reading properly been on and off all year no symptoms just the light .i still have warranty .any one else had the same code as me
 

·
Registered
Joined
·
40 Posts
My engine light came on, but no code. So yes, indirectly, it has happened to me. For the last couple weeks, no engine light has appeared. It is still running well.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
40 Posts
I have a 2019, check engine light on, cant find any error codes, toggled through screen and nothing
My 2018 did the same thing. Next time I ran it (house chores), I did not have a light (nor codes). Checked oil as recommended above - no problem. Got me scratching my head.

Runs fine the last few times out.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2 Posts
my 2018 also has the check engine light on and off its code 520194 for throttle safety resistors not reading properly been on and off all year no symptoms just the light .i still have warranty .any one else had the same code as me
I had that code also. I tightened my star drive screws that secure the throttle to the handle bars and it hasn't come back on.
 
1 - 12 of 12 Posts
Top