Polaris ATV Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1
Ok. My best friend bought two new polaris wheelers based on my recommendation because I have two myself. A 2019 850sp and an 2019 570 both eps. He bought a 450 and a 570 no eps. The 570 no issue. The 450. Second ride threw a code 520194 7. To the dealer it went. A week later they said come pick it up. What they did was the factory zip tie on the tps had broken and they electrical taped it back on. First ride bam. Back on. Back to the dealer. Three weeks there. Wouldn’t return calls finally went up there with them and they said they couldn’t replicate the problem and they couldn’t do anything with it. Told em to keep at it. Two more weeks. Nothing. Finally fed up. This dealer absolute blows. They just don’t want to do warranty work. They called polaris directly as the wheeler has been down the two months they’ve owned it. Polaris finally calls back and tells them to be patient. That’s it. Wait another week no calls from dealer and can’t get them to return calls. Go there wheeler in same spot. They say they can’t do anything with it. Needless to say my buddy is pissed at this point with the lack of any help after dropping 10k on their product. So he brings it home and we ride today to test it. No code today put idles like crap and seems to be missing throughout the driving range. No other dealer within an hour and a half and they’ve lost two months of warranty and still have a brand new atv that can’t be used. We checked throttle freeplay and the contacts in the throttle housing. Any ideas or help would be appreciated as it looks like if this thing is gonna be fixed we are gonna have to do it ourselves as our dealer is a joke and polaris just does not seem to care at all. Sorry about all this but it is certainly frustrating. Thanks for any and all help. Btw is fresh gas and the normal things have been checked.
 

·
Premium Member
Joined
·
9,736 Posts
So as of right now any codes??
 

·
Registered
Joined
·
47 Posts
Discussion Starter #4
Isles up and down and high. And misses while riding. No real hesitation just like missing every third or fourth spark
 

·
Registered
Joined
·
47 Posts
Discussion Starter #5
Also. If its started from cold will run fine for about two hours. Then start acting up. Once it’s cools completely down back to normal for a few hours
 

·
Premium Member
Joined
·
9,736 Posts
Hmmm cold be the fuel pump over heating and failing.
 

·
Registered
Joined
·
47 Posts
Discussion Starter #7
So infuriating. Cant believe the dealer just told us they can’t do anything with it and hung us out to dry.
 

·
Premium Member
Joined
·
9,736 Posts
  • Like
Reactions: jsnance

·
Premium Member
Joined
·
9,736 Posts
Yeah man F that dealer!!! Never ever do business with them again. Drive to the next closest or one with a good rep.
 

·
Registered
Joined
·
47 Posts
Discussion Starter #10
Yeah they blow. Polaris kinda blew us off too. I was really shocked by that. The next closest is almost two hours away.
 

·
Premium Member
Joined
·
9,736 Posts
Polaris should extend the warranty in good faith.
 

·
Registered
Joined
·
47 Posts
Discussion Starter #14
No more responses ? Still the same issue. Also it tends to ride fine for a couple of hours from a cold start then acts up and repeats. Still no help from polaris. They r just waiting for the warranty to expire. Any additional ideas would be great
 

·
Registered
Joined
·
1,811 Posts
I’d call and message(paper trail) Dealership and Polaris both and demand action and if they don’t they WILL here from your attorney who’s fees will be included in settlement! :mad:
 

·
Registered
Joined
·
47 Posts
Discussion Starter #16
Its coming to that I’m afraid. I know it’s tough to pin down but we haven’t even been able to ride it a single time for it’s issue and the dealer nor polaris seems to give a shiznit. Between us we’ve bought in the last seven months an 850 sp two 570s and the 450. Was considering another 450 for my wife. Don’t think so now.
 
1 - 18 of 18 Posts
Top