Polaris ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
Back again guys for another great season of riding. Before I put the sportsman up last season I put on some new Bighorn 2.0 tires. The front tires look good to go, but the rear tires look under inflated. Is that normal for the Bighorns? I get that more tread increases grab but I don’t want the tires to fall off the rim. Also as I was putting the wheeler away last season I pushed on the side wall of the tires and heard a quick release of air before it sounded like it closed up. Normal?
 

·
Moderator
Joined
·
10,387 Posts
Uhh… They won't still be inflated from last season. All tires lose pressure over time. Put around 6 psi in all 4 of them and go riding.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #4
Uhh… They won't still be inflated from last season. All tires lose pressure over time. Put around 6 psi in all 4 of them and go riding.
I was talking even before I put it away. It’s stored in my garage and they were still at 6 psi
 

·
Premium Member
Joined
·
9,428 Posts
ok so 8 is my ceiling for pressure. just adjust accordingly I go as low as 3psi but I have beadlocks. and yes the wide BH 2.0s look flat with around 4-6psi in them especially on 14" rims. I get that all the time.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #6
ok so 8 is my ceiling for pressure. just adjust accordingly I go as low as 3psi but I have beadlocks. and yes the wide BH 2.0s look flat with around 4-6psi in them especially on 14" rims. I get that all the time.
ok maybe I’ll lower it back down to 6 psi then. ??
 
1 - 6 of 6 Posts
Top