Polaris ATV Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
1999 Polaris Diesel AWD will only work in reverse with override button pushed.
This is the model where the speedometer does not control anything. It is just a speedometer (needle) with a light bulb.

The AWD light turns on when I press the override button and the AWD does engage. When I put it in High or Low forward gear the light turns off and there’s no more AWD.

AWD does work in any gear if I directly send 12 volts to the hubs through a 12 volt bypass at the hubs wire harness connectors under the hood.

I’d like to make the AWD work through the switch. Any suggestions where I should trouble shoot? Why would the AWD work I reverse but shut off when shifted into forward?

On a side note, why would it be necessary to ever turn off the AWD? I get less wear on the mechanicals, but would there be another practical reason?
 

·
Registered
Joined
·
15,819 Posts
The switch in the shifter box is not letting the speed limiter box know it's in forward the reverse indicator switch is working, but the forward switch is not making contact.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
The switch in the shifter box is not letting the speed limiter box know it's in forward the reverse indicator switch is working, but the forward switch is not making contact.
Bingo! That’s it. I took out the switch from the shifter box and reverse works but not forward. I can’t seem to find a replacement switch anywhere. Anyone have a part number or know where I can find a replacement switch?

Thanks again!
 

·
Registered
Joined
·
15,819 Posts
The switch is NLA - have to find used one - part number was 3233490 and it was used on:
1999 DIESEL A99CH45CA
1999 INTL DIESEL A99CH45IA
2011 RANGER 400 HO R11RH45AG/AH/AR
2010 RANGER 4X4 400 HO R10RH45AG/AH/AR
 
1 - 5 of 5 Posts
Top