Polaris ATV Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
HI,

I have a 2004 ATP (Sportsman) 500 HO and it dies after it warms up. The fan may come on once or twice then it shuts down. Can restart but dies right away. Let it cool down and we're back going but stops again once it heats up. No hot light.

New "etc", carb (needed it), oil, antifreeze already done.

Where to go? Fan resistance? Temp sensor?

Thanks!
 

·
Registered
Joined
·
563 Posts
I wont swear to this but I think if the fuel pump relay is going bad it will shut off when hot and when it cools down then it will work again.
 

·
Premium Member
Joined
·
20,001 Posts
And welcome to the board!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
I wont swear to this but I think if the fuel pump relay is going bad it will shut off when hot and when it cools down then it will work again.
Thanks for the advice.

Is that part of the pump or a separate electrical item?
 

·
Registered
Joined
·
563 Posts
I was just thinking about that and I dont think the 04 has a fuel pump relay since no efi.They have something more in the lines of a diaphram type deal.So thats probably not the problem.Yours wouldnt happen to be an 04 1/2 would it?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
I was just thinking about that and I dont think the 04 has a fuel pump relay since no efi.They have something more in the lines of a diaphram type deal.So thats probably not the problem.Yours wouldnt happen to be an 04 1/2 would it?
I beleive it is an 04 1/2.
 

·
Registered
Joined
·
563 Posts
Did you have the ECM recall done if it is 04.5?Only certain ones had that issue.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
:eek5:
Did you have the ECM recall done if it is 04.5?Only certain ones had that issue.
I wasn't aware there was a recall. I'll have to check my records though. I think I changed it out last fall myself, but now I can't remeber exactly what I changed...
 

·
Registered
Joined
·
1 Posts
2000 sportsman

I have a very similar problem. Every summer I go through it, ya I know I should have fixed it by now. The problem is I don't know what is wrong with it. I can see that the inline filter doesn't have much fuel in it, so I pressure up the tank by blowing in it. I try not to let people see me do this ha ha. Then I choke it and try to start it. Sometimes I have to repeat that a few times. I wish I knew what the problem was, so I could fix it.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #11
I have a very similar problem. Every summer I go through it, ya I know I should have fixed it by now. The problem is I don't know what is wrong with it. I can see that the inline filter doesn't have much fuel in it, so I pressure up the tank by blowing in it. I try not to let people see me do this ha ha. Then I choke it and try to start it. Sometimes I have to repeat that a few times. I wish I knew what the problem was, so I could fix it.
WORD.

This isn't helping me.

Word.

Moving forward, never blow yourself...even if you can...what ever. Specialiay when some JA is whatching ya...:AR15firing:
 
1 - 11 of 11 Posts
Top