Polaris ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
2007 Polaris 500 EFI . When it is cold outside , it is dead ,no dash no lights ,no start . If I put it in the shop where it is warm . it comes to life in about an hour. I changed the power disribution module , no change .Any suggestions .
 

·
Registered
Joined
·
12 Posts
2007 Polaris 500 EFI . When it is cold outside , it is dead ,no dash no lights ,no start . If I put it in the shop where it is warm . it comes to life in about an hour. I changed the power disribution module , no change .Any suggestions .
Very simple. You need new battery. And while you are at it purchase a tender. It will keep your battery living a long life in cold weather
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
2007 Polaris 500 EFI . When it is cold outside , it is dead ,no dash no lights ,no start . If I put it in the shop where it is warm . it comes to life in about an hour. I changed the power disribution module , no change .Any suggestions .
Very simple. You need new battery. And while you are at it purchase a tender. It will keep your battery living a long life in cold weather
Hello , I put a new battery in & a new power disribution module , checked the ground . Still nothing, until I put in the shop for an hour & it warms up .
 

·
Registered
Joined
·
12 Posts
Sorry, your original post stated only the distribution model.

Still, all indications are toward your battery being bad or too cold. How cold are you talking? Little motorcycle batteries don't like it much below 25.

It could be a bad ground but you said you had cleaned all the contacts. You might want to double check that again.

If it has to stay outside I would look into a tender.

Carl
 
1 - 5 of 5 Posts
Top