Polaris ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
A week ago, me and my brother were riding down the road when his shades blew off his face and he turned to go back and get them. Well...... he didn't know he had it in 4x4 and we were on pavement, you can imagine what happened. Going about 50-55 it turned over on him towards the right hand side and landed on the handle bars. We got it turned back over but I had to pull him home. Wouldn't start or turn over. He broke off his right brake handle from the bars but didn't bust a brake line. Also broke his speedo but the LCD display works. Now it turns over but will not fire up. Fuses are good and I checked the throttle, what else could it be?? It's an 08 500 H.O. Thanks!
 

·
Registered
Joined
·
40 Posts
check all wire conections on the throttle and i had a scrambler 500 and the main light control with the kill switch and lights/start button the clip was wore out and the plug would vibrate out of the socket and cause it to shut off and not start all the time.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
His hand looked like he stuck it in the meat grinder. I know they weren't meant to be rode on the pavement but we took a shortcut home and this happened right in front of our house....We live out in the country so we have the reallllllllly rough asphalt. I still haven't had any luck with getting it started..... I'm starting to think the fuel pump got messed up.
 

·
Registered
Joined
·
40 Posts
oh those are fuel injected hunh. i was thinking maby the float was stuck in the carb or something. but that rules that out.
 

·
Registered
Joined
·
601 Posts
I would check spark and fuel....and take it from there...MUDDIE
 
1 - 6 of 6 Posts
Top