Polaris ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
I have a 2012 sportsman 500 HO when I ride and try to go top speed its like the motor just sputters and wont rev up and loses power. last time thus happend I just put a can of seafoam and it fixed it. this time seafoam aint working. any suggestions? plz help I filled up with premium gas and h ave been revvving it up trying to get the bad gas too pas threw. is this a good idea? what.can I do?
 

·
Registered
Joined
·
2,412 Posts
sounds like you need to do a thorough cleaning of the carb. Also check for air leaks around the airbox. You can do that by running it and spraying starter fluid and checking if the bike speeds up then you have an air leak.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #3
anyone know a good carb cleaning tutorial?
 

·
Registered
Joined
·
34 Posts
Discussion Starter #4
can I rev it up in neutral? will that hurt it? I was trying to get the trash to pass threw. how do I clean the carb?
 

·
Registered
Joined
·
4,629 Posts
I would suggest getting a service manual and watching some YouTube videos or take it to a professional for cleaning.

It's not hard to do but there are a few really small pieces and springs that can easily get misplaced. I found the hardest part was getting the screws for the float bowl off bec they wanted to strip. I ended up using an impact driver.


Rather be riding, instead I'm using Tapatalk
 

·
Registered
Joined
·
2,980 Posts
I have a 2012 sportsman 500 HO when I ride and try to go top speed its like the motor just sputters and wont rev up and loses power. last time thus happend I just put a can of seafoam and it fixed it. this time seafoam aint working. any suggestions? plz help I filled up with premium gas and h ave been revvving it up trying to get the bad gas too pas threw. is this a good idea? what.can I do?
This answer is more of a question, but something very similar happened to my buddy 2010 500HO a few days ago, and all it was ,his choke had backed out a little and gave the same symptoms you described. Have you checked your choke?
 
1 - 6 of 6 Posts
Top