Polaris ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I posted about this earlier. my machine has had intermittent starting problems. when I turn the key on my fuel pump doesn't engage. today, at first, the pump wouldn't engage. now I get no thing to the starter or winch. the cluster does light up. every time this has happened I had either driven in or plowed snow with the temp at or below zero. I cleaned the ground connections at the battery, block and the bolt. any ideas?
 

·
Registered
Joined
·
1,465 Posts
When your done plowing get that battery hooked up to a battery tender. I've read about guys having issues after plowing..
 

·
Registered
Joined
·
575 Posts
I have this problem if I forget to plug my battery tender in. I got mine at tractor supply for $20. I'd say that will cure all your problems.
 

·
Registered
Joined
·
737 Posts
When you have this problem check and see how many volts you have at the battery. If it is low the battery tender should take care of it. If you have over 12 volts and still having problems I would think it would be something else.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
I put a heat lamp under the machine last night and it started this morning. I finished plowing with it today and hooked a tender to it and the light on the tender showed it had a full charge. is it worth my while to get the bigger battery? I started another thread to get some opinions too. thanx for your help.
 
1 - 6 of 6 Posts
Top