Polaris ATV Forum banner

1 - 16 of 16 Posts

·
Registered
2012 Polaris 850HQ Sportsman
Joined
·
7 Posts
Discussion Starter #1
Use my 4 wheeler every day - almost always with difficulty. Turn the key on, start it, 75:25 chance that CHECK ENGINE LIGHT will come on. If it does, nothing works - can't shift gears, won't run properly or if it does run, it limps along surging and pausing. You can goose the throttle multiple times and MAYBE the CHECK ENGINE LIGHT will go off. If CHECK ENGINE LIGHT goes OFF, and if you can quickly shift into gear and go without it coming back on - you are fine for however long the trip is. If the CHECK ENGINE LIGHT comes back on when you arrive at your destination and are idling, it is locked in gear and requires turning off the engine to put it in park because gear shift WILL NOT move if CHECK ENGINE LIGHT is on. CHECK ENGINE LIGHT comes on ONLY at idle - if you reach 2 MPH, it will run perfectly.

Not a fan of throwing parts at it hoping for a fix. I have seen several similar posts but not one exactly like this. Have been toying with replacing TPS (throttle position sensor) but it is $$$.
 

·
Registered
Joined
·
1,047 Posts
Have you ever tried to retrieve the code(s) set when the CEL comes on?

Mark
 

·
Registered
2012 Polaris 850HQ Sportsman
Joined
·
7 Posts
Discussion Starter #3
Thanks Mark for your response. I'm old and don't know how to get the code set. I bought it second hand years ago with no instruction manual.
 

·
Registered
2017 Sportsman 850SP
Joined
·
913 Posts
Well let’s start with what year it is, then we can explain how to retrieve codes or possibly provide you with a manual. Once you know the codes you can narrow down the culprit. It’s an electrical issue and likely something to do with the TPS. But without codes it’s impossible to tell.
 

·
Registered
2017 Sportsman 850SP
Joined
·
913 Posts
Use the following procedure to view active codes that occur when the
key is on.
1. Place the transmission in PARK.
2. Press and release the SELECT button until the flashing check
engine warning indicator appears in the display.
3. A set of two numbers will also appear in the display.
• The 2-6 digit suspect parameter number (SPN) in the information area
indicates which component is generating the fault code.
• The 1-2 digit failure mode indicator (FMI) number in the clock area indi-
cates the fault mode, such as open or short circuit.
Tip: More than one fault may be active. Press and hold the MODE button to tog-
gle through all currently active diagnostic codes.
 

·
Registered
Joined
·
1,047 Posts
Download Owner's Manuals here.......


Mark
 

·
Registered
2012 Polaris 850HQ Sportsman
Joined
·
7 Posts
Discussion Starter #7
For GMartino100 - As far as I know, the ATV is a 2012 Sportsman Touring 850 HQ EFI

Thanks for your response and your patience!

Using SELECT button as MODE button shows no number at all in speedo area. Following your instructions, this is what I saw.
When I turn key on, check engine light is
on whether started or not. I do not have
to use SELECT button. Cycling through
with SELECT button – these are results:

Key on / engine off Engine running
0 RPM 1300 RPM
214.3 or 214.4 214.3 or 214.4
0.0 0.0
P CK ENG
1348 mi 1348 mi
Trip 1 0mi Trip 1 0 mi
Trip 2 0 mi Trip 2 0 mi































































When I turn key on, check engine light is

on whether started or not. I do not have

to use SELECT button. Cycling through

with SELECT button – these are results:



Key on / engine off Engine running

0 RPM 1300 RPM

214.3 or 214.4 214.3 or 214.4

0.0 0.0

P CK ENG

1348 mi 1348 mi

Trip 1 0mi Trip 1 0 mi

Trip 2 0 mi Trip 2 0 mi

Trip 2 0 mi Trip 2 0 mi
 

·
Registered
2012 Polaris 850HQ Sportsman
Joined
·
7 Posts
Discussion Starter #8
Mark
Thanks - I downloaded an owners manual for a Sportsman 850HG EFI Touring and got some instructions for trying to suss out error codes but so far, am still stuck.
 

·
Registered
2017 Sportsman 850SP
Joined
·
913 Posts
Ok when you toggle through and get to the “CK ENG” Display, press and hold the mode button. That should give you the code.
 
  • Like
Reactions: Puzzled

·
Registered
2012 Polaris 850HQ Sportsman
Joined
·
7 Posts
Discussion Starter #11
I finally got a code today - 590194 / 7. When I looked that up in the Polaris manual, this is what I found "Throttle Stuck 520194 7". The throttle has never seemed to have been stuck however, 'goosing' the throttle in park will sometimes cause the CIL to go off. When CIL is on, gear shift is frozen in place (in whatever gear) and engine seems to be in a 'limp mode'. Still puzzled...
 

·
Registered
Joined
·
1,047 Posts
Stuck throttle may not seem what it is. The safety switch at the throttle (under the cover) is probably responsible for setting the code because the throttle cable may be out of adjustment. There is a throttle cable adjuster located on the right side handlebar. I'm not in a position at this moment to give you the adjustment procedure.....others may chime in to confirm and advise.

Mark
 

·
Registered
19’ 850SP Camo. MtAiry Maryland
Joined
·
911 Posts
Mark is correct, if the cable is out of adjustment it will throw that code and act funny. It’s definitely the first thing to check
 

·
Registered
2012 Polaris 850HQ Sportsman
Joined
·
7 Posts
Discussion Starter #14
The micro switch was cleaned and lubricated today and the throttle cable was lubricated. It seemed to correct the problem. This week will prove or disprove if that was the problem. I am hopeful. Thanks guys for your help. I'll post again at the end of this week.
 

·
Registered
19’ 850SP Camo. MtAiry Maryland
Joined
·
911 Posts
The micro switch was cleaned and lubricated today and the throttle cable was lubricated. It seemed to correct the problem. This week will prove or disprove if that was the problem. I am hopeful. Thanks guys for your help. I'll post again at the end of this week.
Sounds good, please also check the throttle cable as the handle bars are turned, mine was hanging up on the center plastic cover and caused some serious chaffing.
 

·
Registered
2012 Polaris 850HQ Sportsman
Joined
·
7 Posts
Discussion Starter #16
Thanks for the hint. The cleaning was only partly successful. Seems now, the CEL comes on intermittently and when it does, engine goes into limp mode and gears are all is locked up but - at least today - the CEL went off after the engine warmed. More trials tomorrow.
 
1 - 16 of 16 Posts
Top