Polaris ATV Forum banner

1 - 20 of 124 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
My 850 xp "hesatates" when i push the throttle from idle/low rpm's. I've had this issue since new, and the dealer have no idea to solve this problem. Thanks from Gunnar, Sweden
 

·
Registered
Joined
·
1,009 Posts
do you mean hesitates like the engine bogs down or sputters?.. if that's the case, something's wrong.. If its more about the fact that it takes a few extra rpms to build up before movement, than its the way the xp is clutched and is normal..
 

·
Registered
Joined
·
5,753 Posts
Have them check the TPS for the proper setting if it's an engine hesitation. If it a get up and go hesitation, that's the stock soft clutching. A clutch kit will cure that and I can ship to Sweden too! Done a bunch of sled stuff for a guy on HCS a few times over the years.
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board!:med:
 

·
Registered
Joined
·
417 Posts
Install a hotter plug. The stock will hesitate, especially in colder climates


Sent from my iPhone using Tapatalk - now Free
 

·
Registered
Joined
·
1,181 Posts
Might be time to take it to a different dealer.
 

·
Registered
Joined
·
1,420 Posts
It's not a clutching problem, it's the Engine, first "splatter" then it revs up.
Mines the same way! 2 dealers around me say it's normal! I thought it was odd too


2013 850ho
Ok! What do you mean "odd"?
Odd as in I don't think it should be that way like the dealer said it was normal. But it's been that way since new so I've just been riding it. Mine has even ALMOST died a few times it was so bad.


2013 850ho
 

·
Registered
Joined
·
43 Posts
Discussion Starter #13
Mines the same way! 2 dealers around me say it's normal! I thought it was odd too


2013 850ho
Ok! What do you mean "odd"?
Odd as in I don't think it should be that way like the dealer said it was normal. But it's been that way since new so I've just been riding it. Mine has even ALMOST died a few times it was so bad.


2013 850ho
I see. Mine HAS died a few times ex. when shifting gears and pull the throttle immideately up to about 40-50%(half throttle). Sorry for my bad English.
 

·
Registered
Joined
·
1,420 Posts
Ok! What do you mean "odd"?
Odd as in I don't think it should be that way like the dealer said it was normal. But it's been that way since new so I've just been riding it. Mine has even ALMOST died a few times it was so bad.


2013 850ho
I see. Mine HAS died a few times ex. when shifting gears and pull the throttle immideately up to about 40-50%(half throttle). Sorry for my bad English.
That's when mine died also was stop change gears get on throttle and just down right stubble down to nothing. But it's not done it that bad in a while now it's just alittle stubble then revs like normal


2013 850ho
 

·
Registered
Joined
·
1,420 Posts

·
Registered
Joined
·
2,350 Posts
09 850 spark plugs
Polaris ATV Forum - View Single Post - 09 850 spark plugs

Sent from my iPhone using Tapatalk - now Free
Thank you! I'll try to replace the plugs, even if I have a little hard to believe that hotter sparkplugs can make this "big" change. But i really hope you'r right with this easy soloution!:)
The 850 models run a bit rich on the bottom end. They are also easy to foul a plug if you start it and only let it sun for a few secs,......like moving it across the garage
 

·
Registered
Joined
·
2,412 Posts
Absolutely they make a big difference. I fouled two sets before I went to the NKG Iridium's and have not had an issue at all. As faawrenchbndr said they run rich and starting and stopping them with out warming them up is very hard on the stock plugs. They carbon foul and then stop working.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #19
Absolutely they make a big difference. I fouled two sets before I went to the NKG Iridium's and have not had an issue at all. As faawrenchbndr said they run rich and starting and stopping them with out warming them up is very hard on the stock plugs. They carbon foul and then stop working.
I can fully understand that Change of sparkplugs solves idle and starting problems, but throttle response?


Sent from my LT25i using Tapatalk
 

·
Registered
Joined
·
43 Posts
Discussion Starter #20
My 850 have been running for about 160 hours with the factory mounted plugs, with no other issues than bad throttle response at low rpm.

Sent from my LT25i using Tapatalk
 
1 - 20 of 124 Posts
Top