Polaris ATV Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
96 2x4 magnum wont rev past 1/3 throttle... put the choke to half choke and it will go to about 1/2 throttle and then the issue starts.

The issue... It cuts out almost to the point of dieing then revs back up to like its going to run fine only to repeat the cycle. It will not die it will not sputter or any anything. just keeps reving up and down. idles great runs great to 1/3 or 1/2 throttle. WOT it cycles.

I have bypassed the fuel pump and rerouted back thru it... no change.
Disconnected the black wire from the cdi unit... no change other than it wont shut off until you reconnect it.
bought a new carb and swapped out the main and pilot jet from new to old... they are clean and with out obstruction.
new plug
adjusted valves, cam is fine.
air box is fine, intake is tight.
etc is dry but has some white calcifying going on... cleaned it.

what the heck is wrong with this machine?
 

·
Registered
Joined
·
3,420 Posts
Have you looked at the spring and the diaphram in the top of the carb?
Make sure vent lines are not pinched or obstructed.
just to make sure-The air box is fully assembled with the snorkle and a pre filter on it.
Check for a pinched/broken spark plug wire(in the area where the fuel tank might come into contact with it. Spark plug boot resistance is good.
Fresh fuel(No possibility of water)
Camshaft lobes have been inspected?
Maybe that info will help.
 
1 - 3 of 3 Posts
Top